Just a couple of days ago, the good folk ‘Cyanogen’ released version 6.0 of their much acclaimed CyanogenMod. To my (and many other people’s) sadness though, it still does not support the Samsung Galaxy S nor any of its other flavours (Vibrant, Captivate, etc).

According to a previous post by the same gentleman, Vibrant support (and hopefully all the rest, by affinity) might be coming to version 6.1. Until this version is released let’s just hold onto that thought and pray they are serious about it!

In the meanwhile, maybe you’d like to give one of the Froyo builds a spin?